I had proposed the idea previously to add an
Object.mapEntries() method, and was told that the committee had already considered pretty much the same idea here,
Object.map(), and did not pursue it.
The reasonings in the github repository are as follows:
Could anyone elaborate on this?
What is this "slippery slope"? Is TC39 worried about a map function being a slippery slope to adding a bunch of other object-helper methods to Object, such as
.some() - similar to what we're doing with our other collection types in this proposal? Or does it mean something else?
Are there other reasons for not wanting such a function?