Unify .slice and splice approaches

Today it is array.slice(start, end) and array.splice(start, length). It should be one way or another - but in both cases.

They're different - slice creates a new array and does not mutate; splice mutates. While toSpliced now exists, they're still conceptually different in that slice creates an array of the same or smaller size; splice is for adding and removing elements at a specific position.

The similarity of the names is unfortunate, but irrelevant.

1 Like