Add "removeInterval(intervalID)" and "removeTimeout(timeoutID)"

I would like to suggest to add global function "removeInterval" which would perform exact same thing as "clearInterval" and global function "removeTimeout" which would perform exactly as "clearTimeout"

In my opinion, "remove..." is much more intuitive name than "clear...". Funny enough, this name is more clear:) We already have a construction "addEventListener" - "removeEventListener".

I've just written a program where I was using this feature for the first time and I intuitively wrote "removeInterval" being 99% sure this is correct function name. Little did I know...

"deleteInterval" and "deleteTimeout" could be added as well.

Those functions aren’t in the language, they’re in HTML, and typically we’d avoid just adding aliases for things anyways.